-{ lib, pkgs, ... }: {
+{ lib, pkgs, modulesPath, ... }: {
imports = [
- <nixos/nixos/modules/installer/cd-dvd/channel.nix>
- <nixos/nixos/modules/profiles/base.nix>
- <nixos/nixos/modules/testing/test-instrumentation.nix>
- <nixos/nixos/modules/virtualisation/qemu-vm.nix>
+ (modulesPath + "/installer/cd-dvd/channel.nix")
+ (modulesPath + "/profiles/base.nix")
+ (modulesPath + "/testing/test-instrumentation.nix")
+ (modulesPath + "/virtualisation/qemu-vm.nix")
];
- nix.binaryCaches = lib.mkForce [ ];
+ nix.settings.substituters = lib.mkForce [ ];
nix.extraOptions = ''
hashed-mirrors =
connect-timeout = 1
system.extraDependencies = with pkgs; [
# List of packages from installer test
curl # To diagnose fetch requests
+ bintools
+ brotli
+ brotli.dev
+ brotli.lib
desktop-file-utils
docbook5
docbook_xsl_ns
- grub
+ kbd.dev
+ kmod.dev
+ libarchive.dev
libxml2.bin
libxslt.bin
nixos-artwork.wallpapers.simple-dark-gray-bottom
ntp
perlPackages.ListCompare
perlPackages.XMLLibXML
+ (python3.withPackages (p: [ p.mistune ]))
shared-mime-info
- stdenvNoCC
sudo
texinfo
unionfs-fuse
xorg.lndir
+
+ stdenvNoCC
];
# Don't try to install bootloaders in a VM