]> git.scottworley.com Git - syncthing-autoregister/blobdiff - lib/test-nixos-rebuild-switch-config.nix
Follow renames in test data
[syncthing-autoregister] / lib / test-nixos-rebuild-switch-config.nix
index a31a39e2d5966f7867d019b6c5441d791a75a527..130a8087324bd7ab9cc51be7291a3f38a4ce186b 100644 (file)
@@ -1,12 +1,12 @@
-{ lib, pkgs, ... }: {
+{ lib, pkgs, modulesPath, ... }: {
   imports = [
   imports = [
-    <nixos/nixos/modules/installer/cd-dvd/channel.nix>
-    <nixos/nixos/modules/profiles/base.nix>
-    <nixos/nixos/modules/testing/test-instrumentation.nix>
-    <nixos/nixos/modules/virtualisation/qemu-vm.nix>
+    (modulesPath + "/installer/cd-dvd/channel.nix")
+    (modulesPath + "/profiles/base.nix")
+    (modulesPath + "/testing/test-instrumentation.nix")
+    (modulesPath + "/virtualisation/qemu-vm.nix")
   ];
 
   ];
 
-  nix.binaryCaches = lib.mkForce [ ];
+  nix.settings.substituters = lib.mkForce [ ];
   nix.extraOptions = ''
     hashed-mirrors =
     connect-timeout = 1
   nix.extraOptions = ''
     hashed-mirrors =
     connect-timeout = 1
   system.extraDependencies = with pkgs; [
     # List of packages from installer test
     curl                # To diagnose fetch requests
   system.extraDependencies = with pkgs; [
     # List of packages from installer test
     curl                # To diagnose fetch requests
+    bintools
+    brotli
+    brotli.dev
+    brotli.lib
     desktop-file-utils
     docbook5
     docbook_xsl_ns
     desktop-file-utils
     docbook5
     docbook_xsl_ns
-    grub
+    kbd.dev
+    kmod.dev
+    libarchive.dev
     libxml2.bin
     libxslt.bin
     nixos-artwork.wallpapers.simple-dark-gray-bottom
     ntp
     perlPackages.ListCompare
     perlPackages.XMLLibXML
     libxml2.bin
     libxslt.bin
     nixos-artwork.wallpapers.simple-dark-gray-bottom
     ntp
     perlPackages.ListCompare
     perlPackages.XMLLibXML
+    (python3.withPackages (p: [ p.mistune ]))
     shared-mime-info
     shared-mime-info
-    stdenvNoCC
     sudo
     texinfo
     unionfs-fuse
     xorg.lndir
     sudo
     texinfo
     unionfs-fuse
     xorg.lndir
+
+    stdenvNoCC
   ];
 
   # Don't try to install bootloaders in a VM
   ];
 
   # Don't try to install bootloaders in a VM