]> git.scottworley.com Git - syncthing-autoregister/blob - lib/test-nixos-rebuild-switch-config.nix
Add stdenvNoCC back as a dep for nixos-rebuild
[syncthing-autoregister] / lib / test-nixos-rebuild-switch-config.nix
1 { lib, pkgs, modulesPath, ... }: {
2 imports = [
3 (modulesPath + "/installer/cd-dvd/channel.nix")
4 (modulesPath + "/profiles/base.nix")
5 (modulesPath + "/testing/test-instrumentation.nix")
6 (modulesPath + "/virtualisation/qemu-vm.nix")
7 ];
8
9 nix.binaryCaches = lib.mkForce [ ];
10 nix.extraOptions = ''
11 hashed-mirrors =
12 connect-timeout = 1
13 '';
14
15 system.extraDependencies = with pkgs; [
16 # List of packages from installer test
17 curl # To diagnose fetch requests
18 bintools
19 brotli
20 brotli.dev
21 brotli.lib
22 desktop-file-utils
23 docbook5
24 docbook_xsl_ns
25 kbd.dev
26 kmod.dev
27 libarchive.dev
28 libxml2.bin
29 libxslt.bin
30 nixos-artwork.wallpapers.simple-dark-gray-bottom
31 ntp
32 perlPackages.ListCompare
33 perlPackages.XMLLibXML
34 (python3.withPackages (p: [ p.mistune ]))
35 shared-mime-info
36 sudo
37 texinfo
38 unionfs-fuse
39 xorg.lndir
40
41 stdenvNoCC
42 ];
43
44 # Don't try to install bootloaders in a VM
45 boot.loader.grub.devices = lib.mkForce [ "nodev" ];
46 }