1 # NixOS configuration that allows a nixosTest virtual machine to "nixos-rebuild switch".
2 # You'll also need to include the config's system.build.toplevel in system.extraDependencies.
4 { lib, pkgs, modulesPath, ... }: {
6 (modulesPath + "/installer/cd-dvd/channel.nix")
7 (modulesPath + "/profiles/base.nix")
8 (modulesPath + "/testing/test-instrumentation.nix")
9 (modulesPath + "/virtualisation/qemu-vm.nix")
12 nix.binaryCaches = lib.mkOverride 90 [ ];
13 nix.binaryCachePublicKeys = lib.mkOverride 90 [ ];
19 system.extraDependencies = with pkgs; [
20 # List of packages from installer test
21 curl # To diagnose fetch requests
28 nixos-artwork.wallpapers.simple-dark-gray-bottom
30 perlPackages.ListCompare
31 perlPackages.XMLLibXML
40 # Don't try to install bootloaders in a VM
41 boot.loader.grub.devices = lib.mkForce [ "nodev" ];