1 # NixOS configuration that allows a nixosTest virtual machine to "nixos-rebuild switch".
2 # You'll also need to include the config's system.build.toplevel in system.extraDependencies.
4 { lib, pkgs, modulesPath, ... }: {
6 (modulesPath + "/installer/cd-dvd/channel.nix")
7 (modulesPath + "/profiles/base.nix")
8 (modulesPath + "/testing/test-instrumentation.nix")
9 (modulesPath + "/virtualisation/qemu-vm.nix")
12 nix.binaryCaches = lib.mkForce [ ];
18 system.extraDependencies = with pkgs; [
19 # List of packages from installer test
20 curl # To diagnose fetch requests
27 nixos-artwork.wallpapers.simple-dark-gray-bottom
29 perlPackages.ListCompare
30 perlPackages.XMLLibXML
39 # Don't try to install bootloaders in a VM
40 boot.loader.grub.devices = lib.mkForce [ "nodev" ];