]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Fix race: Re-register on file change
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 5ab4efac5028910e3c9cbc882c9a83f9e290d87e..617f672e4da38f157986db9d2f7b2d1ef3be764b 100644 (file)
@@ -57,31 +57,41 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
 
 
       def verifyDeviceIDSet(machine, expectedDevice):
-          machine.succeed(
+          machine.wait_until_succeeds(
               '(( "$(nix eval --raw -f "<nixos/nixos>" config.services.syncthing.declarative.devices.%s.id | wc -c)" == 63 ))'
               % expectedDevice
           )
 
 
+      def getDeviceFile(machine):
+          machine.copy_from_vm("${deviceIDFilename}")
+
+
+      def putDeviceFile(machine):
+          hostDeviceIDFilename = os.path.join(
+              os.environ["out"],
+              os.path.basename("${deviceIDFilename}"),
+          )
+          machine.copy_from_host(
+              hostDeviceIDFilename, "${deviceIDFilename}"
+          )
+          machine.succeed("chown syncthing ${deviceIDFilename}")
+
+
       configurationWithDeviceIDs = (
           "${configurationWithDeviceIDs}"
       )
 
-      hostDeviceIDFilename = os.path.join(
-          os.environ["out"],
-          os.path.basename("${deviceIDFilename}"),
-      )
-
+      start_all()
       a.wait_for_unit("syncthing-autoregister.service")
       setConfig(a, configurationWithDeviceIDs)
       verifyDeviceIDSet(a, "a")
-      a.copy_from_vm("${deviceIDFilename}")
+      getDeviceFile(a)
 
-      b.copy_from_host(
-          hostDeviceIDFilename, "${deviceIDFilename}"
-      )
-      b.succeed("chown syncthing ${deviceIDFilename}")
+      b.wait_for_unit("syncthing-autoregister.service")
+      putDeviceFile(b)
       setConfig(b, configurationWithDeviceIDs)
       verifyDeviceIDSet(b, "a")
+      verifyDeviceIDSet(b, "b")
     '';
   })