)
+ def getDeviceFile(machine):
+ machine.copy_from_vm("${deviceIDFilename}")
+
+
+ def putDeviceFile(machine):
+ hostDeviceIDFilename = os.path.join(
+ os.environ["out"],
+ os.path.basename("${deviceIDFilename}"),
+ )
+ machine.copy_from_host(
+ hostDeviceIDFilename, "${deviceIDFilename}"
+ )
+ machine.succeed("chown syncthing ${deviceIDFilename}")
+
+
configurationWithDeviceIDs = (
"${configurationWithDeviceIDs}"
)
- hostDeviceIDFilename = os.path.join(
- os.environ["out"],
- os.path.basename("${deviceIDFilename}"),
- )
-
a.wait_for_unit("syncthing-autoregister.service")
setConfig(a, configurationWithDeviceIDs)
verifyDeviceIDSet(a, "a")
- a.copy_from_vm("${deviceIDFilename}")
+ getDeviceFile(a)
- b.copy_from_host(
- hostDeviceIDFilename, "${deviceIDFilename}"
- )
- b.succeed("chown syncthing ${deviceIDFilename}")
+ putDeviceFile(b)
setConfig(b, configurationWithDeviceIDs)
verifyDeviceIDSet(b, "a")
+ b.wait_for_unit("syncthing-autoregister.service")
+ verifyDeviceIDSet(b, "a")
+ verifyDeviceIDSet(b, "b")
'';
})