]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
getDeviceFile() & putDeviceFile()
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 4ff3670a3df0c35a53522b48f2c3ffe1730cfaa3..6520c9f35e5067a9e76fb6b166ccb735c52e8218 100644 (file)
@@ -63,6 +63,21 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
           )
 
 
           )
 
 
+      def getDeviceFile(machine):
+          machine.copy_from_vm("${deviceIDFilename}")
+
+
+      def putDeviceFile(machine):
+          hostDeviceIDFilename = os.path.join(
+              os.environ["out"],
+              os.path.basename("${deviceIDFilename}"),
+          )
+          machine.copy_from_host(
+              hostDeviceIDFilename, "${deviceIDFilename}"
+          )
+          machine.succeed("chown syncthing ${deviceIDFilename}")
+
+
       configurationWithDeviceIDs = (
           "${configurationWithDeviceIDs}"
       )
       configurationWithDeviceIDs = (
           "${configurationWithDeviceIDs}"
       )
@@ -70,16 +85,9 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
       a.wait_for_unit("syncthing-autoregister.service")
       setConfig(a, configurationWithDeviceIDs)
       verifyDeviceIDSet(a, "a")
       a.wait_for_unit("syncthing-autoregister.service")
       setConfig(a, configurationWithDeviceIDs)
       verifyDeviceIDSet(a, "a")
-      a.copy_from_vm("${deviceIDFilename}")
+      getDeviceFile(a)
 
 
-      b.copy_from_host(
-          os.path.join(
-              os.environ["out"],
-              os.path.basename("${deviceIDFilename}"),
-          ),
-          "${deviceIDFilename}",
-      )
-      b.succeed("chown syncthing ${deviceIDFilename}")
+      putDeviceFile(b)
       setConfig(b, configurationWithDeviceIDs)
       verifyDeviceIDSet(b, "a")
     '';
       setConfig(b, configurationWithDeviceIDs)
       verifyDeviceIDSet(b, "a")
     '';