]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Name hostDeviceIDFilename
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 803013d4dab2881615cd5345c0dd3333d6f245c9..5ab4efac5028910e3c9cbc882c9a83f9e290d87e 100644 (file)
@@ -49,6 +49,9 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
     };
 
     testScript = ''
+      import os
+
+
       def setConfig(machine, config):
           machine.copy_from_host(config, "/etc/nixos/configuration.nix")
 
@@ -64,8 +67,21 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
           "${configurationWithDeviceIDs}"
       )
 
+      hostDeviceIDFilename = os.path.join(
+          os.environ["out"],
+          os.path.basename("${deviceIDFilename}"),
+      )
+
       a.wait_for_unit("syncthing-autoregister.service")
       setConfig(a, configurationWithDeviceIDs)
       verifyDeviceIDSet(a, "a")
+      a.copy_from_vm("${deviceIDFilename}")
+
+      b.copy_from_host(
+          hostDeviceIDFilename, "${deviceIDFilename}"
+      )
+      b.succeed("chown syncthing ${deviceIDFilename}")
+      setConfig(b, configurationWithDeviceIDs)
+      verifyDeviceIDSet(b, "a")
     '';
   })