]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Follow renames in test data
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 29a0bdf730cbc85c2c910038341331fc6d86d422..510b5c9ec9db3c088c9517cb720d015595130ae5 100644 (file)
@@ -35,7 +35,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
         {
           services.syncthing = {
             enable = true;
-            folders.forDeps.path = "/nope";
+            settings.folders.forDeps.path = "/nope";
           };
         }
       ];
@@ -71,7 +71,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
       pkgs.writeText "configuration-with-folder.nix" ''
         { config, ... }: {
           imports = [ ${configurationWithDeviceIDs} ];
-          services.syncthing.folders.foo = {
+          services.syncthing.settings.folders.foo = {
             devices = [ "a" "b" ];
             path = "''${config.services.syncthing.dataDir}/foo";
           };
@@ -97,7 +97,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
 
       def verifyDeviceIDSet(machine, expectedDevice):
           machine.wait_until_succeeds(
-              '(( "$(nix --experimental-features nix-command eval --impure --raw --expr "(import <nixos/nixos> {}).config.services.syncthing.declarative.devices.%s.id" | wc -c)" == 63 ))'
+              '(( "$(nix --experimental-features nix-command eval --impure --raw --expr "(import <nixos/nixos> {}).config.services.syncthing.settings.devices.%s.id" | wc -c)" == 63 ))'
               % expectedDevice
           )