]> git.scottworley.com Git - syncthing-autoregister/blobdiff - modules/syncthing-autoregister.nix
Enable option for auto-registration
[syncthing-autoregister] / modules / syncthing-autoregister.nix
index d1f0a7ce117f01bc2217bf93522490a6124f2d86..158cd520f5c2d787c6168fa0990fc2f1c5d657b2 100644 (file)
@@ -1,11 +1,20 @@
 { config, lib, pkgs, ... }:
+with lib;
 let
+  cfg = config.services.syncthing.autoRegister;
   localpkgs = import ../. { inherit pkgs; };
   register-script = pkgs.writeShellScript "syncthing-autoregister-script" ''
     ${localpkgs.syncthing-set-id}/bin/syncthing-set-id /tmp/syncthing-auto-register-test-device-ids.nix
   '';
 in {
-  config = {
+  options = {
+    services.syncthing.autoRegister = {
+      enable = mkEnableOption ''
+        Automatically write the local syncthing device id to /tmp/syncthing-auto-register-test-device-ids.nix
+      '';
+    };
+  };
+  config = mkIf cfg.enable {
     systemd.services.syncthing-autoregister = {
       after = [ "syncthing.service" "syncthing-init.service" ];
       wantedBy = [ "multi-user.target" ];