- setConfig(machine, initialConfiguration)
- machine.wait_for_unit("syncthing-autoregister.service")
- setConfig(machine, configurationWithDeviceIDs)
- machine.succeed(
- '(( "$(nix eval --raw -f "<nixos/nixos>" config.services.syncthing.declarative.devices.machine.id | wc -c)" == 63 ))'
+ a.wait_for_unit("syncthing-autoregister.service")
+ setConfig(a, configurationWithDeviceIDs)
+ verifyDeviceIDSet(a, "a")
+ a.copy_from_vm("${deviceIDFilename}")
+
+ b.copy_from_host(
+ os.path.join(
+ os.environ["out"],
+ os.path.basename("${deviceIDFilename}"),
+ ),
+ "${deviceIDFilename}",