]> git.scottworley.com Git - syncthing-autoregister/blobdiff - modules/syncthing-autoregister.nix
Follow renames in test data
[syncthing-autoregister] / modules / syncthing-autoregister.nix
index 6276352f67b558773e4349017f694e151e0aa20d..710c7a42fff96f05e0a026b52b8c0435df439291 100644 (file)
@@ -17,11 +17,10 @@ in {
       '';
       path = mkOption {
         type = types.path;
-        default = "/tmp/syncthing-auto-register-test-device-ids.nix";
         description = ''
           Path of nix module file to write our syncthing
           device id into.  It will be written into
-          services.syncthing.declarative.devices.<hostname>.id.  This file
+          services.syncthing.devices.<hostname>.id.  This file
           can be imported as a NixOS module.
 
           We recommend using a separate file just for this purpose.  I.e.,
@@ -46,6 +45,20 @@ in {
         ExecStart = register-script;
       };
     };
+    systemd.services.syncthing-reregister = {
+      after = [ "syncthing-autoregister.service" ];
+      script = ''
+        ${pkgs.coreutils}/bin/sleep 1
+        ${pkgs.systemd}/bin/systemctl restart syncthing-autoregister
+      '';
+      serviceConfig = {
+        Type = "oneshot";
+      };
+    };
+    systemd.paths.syncthing-reregister = {
+      pathConfig.PathChanged = cfg.path;
+      wantedBy = [ "multi-user.target" ];
+    };
   };
 }