]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Follow services.syncthing.declarative rename
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 9b0b76f0d0a7fcdc3c951b8ecfc97d95920c8d8a..29a0bdf730cbc85c2c910038341331fc6d86d422 100644 (file)
@@ -26,7 +26,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
       modules = [ "${vmConfiguration}" ];
     };
 
-    # Also include a syncthing configuration with a declarative device id
+    # Also include a syncthing configuration with a device id
     # because using this feature pulls in additional dependencies.
     evaluatedSyncthingDeclarativeConfiguration = import <nixos/nixos/lib/eval-config.nix> {
       system = builtins.currentSystem;
@@ -35,7 +35,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
         {
           services.syncthing = {
             enable = true;
-            declarative.folders.forDeps.path = "/nope";
+            folders.forDeps.path = "/nope";
           };
         }
       ];
@@ -71,7 +71,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
       pkgs.writeText "configuration-with-folder.nix" ''
         { config, ... }: {
           imports = [ ${configurationWithDeviceIDs} ];
-          services.syncthing.declarative.folders.foo = {
+          services.syncthing.folders.foo = {
             devices = [ "a" "b" ];
             path = "''${config.services.syncthing.dataDir}/foo";
           };