]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Name deviceIDFilename
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 1a6b360bc28ebd6632598b43781d42b4a591b082..803013d4dab2881615cd5345c0dd3333d6f245c9 100644 (file)
@@ -1,5 +1,6 @@
 import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
   let
+    deviceIDFilename = "/tmp/syncthing-auto-register-test-device-ids.nix";
     configuration = pkgs.writeText "configuration.nix" ''
       { pkgs, ... }: {
         imports = [
@@ -11,7 +12,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
           openDefaultPorts = true;
           autoRegister = {
             enable = true;
-            path = "/tmp/syncthing-auto-register-test-device-ids.nix";
+            path = "${deviceIDFilename}";
           };
         };
         environment.systemPackages = with pkgs; [ nix ];
@@ -34,7 +35,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
         {
           imports = [
             ${configuration}
-            /tmp/syncthing-auto-register-test-device-ids.nix
+            ${deviceIDFilename}
           ];
         }
       '';