]> git.scottworley.com Git - syncthing-autoregister/blobdiff - tests/automatic-enrollment.nix
Follow nix version bump that changed the eval command line interface
[syncthing-autoregister] / tests / automatic-enrollment.nix
index 184bcc75e99c455f335d888479f8866f01b95c1d..9b0b76f0d0a7fcdc3c951b8ecfc97d95920c8d8a 100644 (file)
@@ -97,7 +97,7 @@ import <nixpkgs/nixos/tests/make-test-python.nix> ({ pkgs, lib, ... }:
 
       def verifyDeviceIDSet(machine, expectedDevice):
           machine.wait_until_succeeds(
-              '(( "$(nix eval --raw -f "<nixos/nixos>" config.services.syncthing.declarative.devices.%s.id | wc -c)" == 63 ))'
+              '(( "$(nix --experimental-features nix-command eval --impure --raw --expr "(import <nixos/nixos> {}).config.services.syncthing.declarative.devices.%s.id" | wc -c)" == 63 ))'
               % expectedDevice
           )