]> git.scottworley.com Git - syncthing-autoregister/blob - lib/test-nixos-rebuild-switch-config.nix
36928b2923d86cc861e35989c661e11d416e9889
[syncthing-autoregister] / lib / test-nixos-rebuild-switch-config.nix
1 { lib, pkgs, modulesPath, ... }: {
2 imports = [
3 (modulesPath + "/installer/cd-dvd/channel.nix")
4 (modulesPath + "/profiles/base.nix")
5 (modulesPath + "/testing/test-instrumentation.nix")
6 (modulesPath + "/virtualisation/qemu-vm.nix")
7 ];
8
9 nix.binaryCaches = lib.mkForce [ ];
10 nix.extraOptions = ''
11 hashed-mirrors =
12 connect-timeout = 1
13 '';
14
15 system.extraDependencies = with pkgs; [
16 # List of packages from installer test
17 curl # To diagnose fetch requests
18 desktop-file-utils
19 docbook5
20 docbook_xsl_ns
21 grub
22 libxml2.bin
23 libxslt.bin
24 nixos-artwork.wallpapers.simple-dark-gray-bottom
25 ntp
26 perlPackages.ListCompare
27 perlPackages.XMLLibXML
28 shared-mime-info
29 stdenvNoCC
30 sudo
31 texinfo
32 unionfs-fuse
33 xorg.lndir
34 ];
35
36 # Don't try to install bootloaders in a VM
37 boot.loader.grub.devices = lib.mkForce [ "nodev" ];
38 }