]> git.scottworley.com Git - rfc1751/blob - default.nix
Release 1.0.0
[rfc1751] / default.nix
1 { pkgs ? import <nixpkgs> { }, lint ? false }:
2 pkgs.python3Packages.callPackage
3 ({ lib, buildPythonPackage, mypy, autopep8, pylint, }:
4 buildPythonPackage rec {
5 pname = "rfc1751";
6 version = "1.0.0";
7 src = lib.cleanSource ./.;
8 nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
9 doCheck = true;
10 checkPhase = "./test.sh";
11 meta = {
12 description =
13 "Command line tool for RFC1751 (aka S/Key) numbers-as-word-lists";
14 homepage = "https://git.scottworley.com/rfc1751";
15 license = lib.licenses.isc;
16 maintainers = with lib.maintainers; [ chkno ];
17 };
18 }) { }