]> git.scottworley.com Git - pinch/blob - shell.nix
Cache nix store paths of generated tarballs
[pinch] / shell.nix
1 { pkgs ? import <nixpkgs> { } }:
2 pkgs.mkShell rec {
3 doCheck = true;
4 buildInputs = with pkgs; [ (python3.withPackages (ps: with ps; [ xdg ])) ];
5 checkInputs = with pkgs; [
6 mypy
7 python3Packages.autopep8
8 python3Packages.pylint
9 ];
10 }