1 { pkgs ? import <nixpkgs> { }, lint ? false }:
5 git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
6 buildPythonPackage rec {
10 url = "https://git.scottworley.com/pub/git/git-cache";
12 hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
14 propagatedBuildInputs = [ backoff ];
15 checkInputs = [ git mypy ];
17 checkPhase = "./test.sh";
20 in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
21 , autopep8, makeWrapper, mypy, pylint, git-cache, }:
22 buildPythonPackage rec {
24 version = "3.0.10-pre";
25 src = lib.cleanSource ./.;
26 buildInputs = [ makeWrapper ];
27 propagatedBuildInputs = [ git-cache ];
28 checkInputs = [ nix_2_3 git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
30 wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
33 checkPhase = "./test.sh";
36 pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage
37 git-cache-fallback { });
38 nix_2_3 = pkgs.nix_2_3 or pkgs.nix;