1 { pkgs ? import <nixpkgs> { }, lint ? false }:
4 git-cache-fallback = { buildPythonPackage, fetchgit, git, mypy, }:
5 buildPythonPackage rec {
9 url = "https://scottworley.com/git-cache.git";
11 sha256 = "06mzjc424988n2s1h25x2bi3mxbk2pnba31zkjljgw4cgw2p9036";
13 checkInputs = [ git mypy ];
15 checkPhase = "./test.sh";
18 in pkgs.python3Packages.callPackage
19 ({ lib, buildPythonPackage, nix, git, autopep8, mypy, pylint, git-cache, }:
20 buildPythonPackage rec {
22 version = "3.0.1-pre";
23 src = lib.cleanSource ./.;
24 propagatedBuildInputs = [ git-cache ];
25 checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
27 checkPhase = "./test.sh";
30 pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage
31 git-cache-fallback { });