]> git.scottworley.com Git - paperdoorknob/blob - default.nix
fetch: Verify caching across sessions
[paperdoorknob] / default.nix
1 { pkgs ? import <nixpkgs> { }, lint ? false }:
2 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, autopep8, mypy
3 , pylint, requests, requests-cache, types-requests }:
4 buildPythonPackage rec {
5 pname = "paperdoorknob";
6 version = "0.0.1";
7 src = lib.cleanSource ./.;
8 propagatedBuildInputs = [ requests requests-cache ];
9 nativeCheckInputs = [ mypy types-requests ]
10 ++ lib.optionals lint [ autopep8 pylint ];
11 doCheck = true;
12 checkPhase = "./test.sh";
13 meta = {
14 description = "A polite glowfic → printable book scraper.";
15 homepage = "https://git.scottworley.com/paperdoorknob";
16 license = pkgs.lib.licenses.gpl3;
17 maintainers = with pkgs.lib.maintainers; [ chkno ];
18 };
19 }) { }