]> git.scottworley.com Git - paperdoorknob/blob - default.nix
Parse HTML
[paperdoorknob] / default.nix
1 { pkgs ? import <nixpkgs> { }, lint ? false }:
2 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, autopep8, mypy
3 , pylint, beautifulsoup4, requests, requests-cache, types-beautifulsoup4
4 , types-requests, xdg-base-dirs }:
5 buildPythonPackage rec {
6 pname = "paperdoorknob";
7 version = "0.0.1";
8 src = lib.cleanSource ./.;
9 propagatedBuildInputs =
10 [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
11 nativeCheckInputs = [ mypy types-beautifulsoup4 types-requests ]
12 ++ lib.optionals lint [ autopep8 pylint ];
13 doCheck = true;
14 checkPhase = "./test.sh";
15 meta = {
16 description = "A polite glowfic → printable book scraper.";
17 homepage = "https://git.scottworley.com/paperdoorknob";
18 license = pkgs.lib.licenses.gpl3;
19 maintainers = with pkgs.lib.maintainers; [ chkno ];
20 };
21 }) { }