]> git.scottworley.com Git - nixos-qemu-vm-isolation/blob - flake.nix
Follow NixOS PR 236656's changes about device naming
[nixos-qemu-vm-isolation] / flake.nix
1 {
2 inputs.nixpkgs.url = "github:NixOS/nixpkgs?ref=nixos-unstable";
3 outputs = { self, nixpkgs, }:
4 let
5 inherit (nixpkgs.lib) genAttrs;
6
7 systems = import ./lib/tier1.nix nixpkgs;
8
9 forAllSystems = genAttrs systems;
10
11 in {
12 nixosModules = {
13 qemu-vm-isolation = import ./modules/qemu-vm-isolation.nix;
14 };
15 checks = forAllSystems (system: {
16 mount-grep = nixpkgs.lib.nixos.runTest
17 (import ./checks/mount-grep.nix nixpkgs.legacyPackages."${system}");
18 });
19 };
20 }