]> git.scottworley.com Git - nix-profile-gc/blobdiff - modules/profile-gc.nix
profile-gc: Confidence gained! Change dryRun default: true → false
[nix-profile-gc] / modules / profile-gc.nix
index ba2821a8fc599e45397c6550c59cb547283d550f..1452e8f22e06fa98166c41b0c1da921c437f80ce 100644 (file)
@@ -14,7 +14,7 @@ in {
       dryRun = lib.mkOption {
         description = "Say what would have been deleted rather than actually deleting profiles";
         type = lib.types.bool;
       dryRun = lib.mkOption {
         description = "Say what would have been deleted rather than actually deleting profiles";
         type = lib.types.bool;
-        default = true;
+        default = false;
       };
       keepLast = lib.mkOption {
         description = ''
       };
       keepLast = lib.mkOption {
         description = ''
@@ -105,7 +105,7 @@ in {
       fi
 
       alive_threshold="$(< ${parse-duration cfg.activeThreshold})"
       fi
 
       alive_threshold="$(< ${parse-duration cfg.activeThreshold})"
-      alive_loginterval="$(< ${parse-duration config.systemd.timers.profile-gc-log-active.timerConfig.OnUnitActiveSec})"
+      alive_loginterval="$(< ${parse-duration cfg.activeMeasurementGranularity})"
       if (( alive_threshold < alive_loginterval ));then
         echo "Liveness threshold is too low.  Not doing any profile garbage collection." >&2
         exit 0
       if (( alive_threshold < alive_loginterval ));then
         echo "Liveness threshold is too low.  Not doing any profile garbage collection." >&2
         exit 0
@@ -197,6 +197,7 @@ in {
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];
+      timerConfig.OnActiveSec = cfg.activeMeasurementGranularity;
       timerConfig.OnUnitActiveSec = cfg.activeMeasurementGranularity;
     };
     systemd.services.profile-gc-log-active = {
       timerConfig.OnUnitActiveSec = cfg.activeMeasurementGranularity;
     };
     systemd.services.profile-gc-log-active = {