dryRun = lib.mkOption {
description = "Say what would have been deleted rather than actually deleting profiles";
type = lib.types.bool;
- default = true;
+ default = false;
};
keepLast = lib.mkOption {
description = ''
fi
alive_threshold="$(< ${parse-duration cfg.activeThreshold})"
- alive_loginterval="$(< ${parse-duration config.systemd.timers.profile-gc-log-active.timerConfig.OnUnitActiveSec})"
+ alive_loginterval="$(< ${parse-duration cfg.activeMeasurementGranularity})"
if (( alive_threshold < alive_loginterval ));then
echo "Liveness threshold is too low. Not doing any profile garbage collection." >&2
exit 0
'';
systemd.timers.profile-gc-log-active = {
wantedBy = [ "timers.target" ];
+ timerConfig.OnActiveSec = cfg.activeMeasurementGranularity;
timerConfig.OnUnitActiveSec = cfg.activeMeasurementGranularity;
};
systemd.services.profile-gc-log-active = {