]> git.scottworley.com Git - hellowebpy/blob - default.nix
Release 1.0.1
[hellowebpy] / default.nix
1 { pkgs ? import <nixpkgs> { }, lint ? false }:
2
3 pkgs.python3Packages.callPackage
4 ({ autopep8, buildPythonPackage, curl, lib, mypy, pylint, }:
5 buildPythonPackage rec {
6 pname = "hellowebpy";
7 version = "1.0.1";
8 src = lib.cleanSource ./.;
9 PIP_DISABLE_PIP_VERSION_CHECK = 1;
10 nativeCheckInputs = [ curl mypy ] ++ lib.optionals lint [ autopep8 pylint ];
11 doCheck = true;
12 checkPhase = "./test.sh";
13 meta = {
14 description = "A minimal 'hello world' python web server.";
15 homepage = "https://git.scottworley.com/hellowebpy";
16 license = pkgs.lib.licenses.gpl3;
17 maintainers = with pkgs.lib.maintainers; [ chkno ];
18 };
19 }) { }