2 inputs = { nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.03"; };
3 outputs = { self, nixpkgs, }:
6 inherit (builtins) attrNames;
7 inherit (nixpkgs.lib) genAttrs;
9 for-supported-systems = genAttrs (attrNames
10 ((import (nixpkgs + "/pkgs/top-level/release.nix")
11 { }).stdenvBootstrapTools));
13 packages = for-supported-systems (system: {
14 inherit (nixpkgs.legacyPackages."${system}".appendOverlays
22 overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
23 overlays = { git-cache = self.overlay; };
25 defaultApp = for-supported-systems (system: {
27 program = "${packages."${system}".git-cache}/bin/git-cache";