]> git.scottworley.com Git - git-cache/blob - flake.nix
Start on 1.4.2
[git-cache] / flake.nix
1 {
2 inputs = { nixpkgs.url = "github:NixOS/nixpkgs/nixos-20.03"; };
3 outputs = { self, nixpkgs, }:
4 let
5
6 inherit (builtins) attrNames;
7 inherit (nixpkgs.lib) genAttrs;
8
9 for-supported-systems = genAttrs (attrNames
10 ((import (nixpkgs + "/pkgs/top-level/release.nix")
11 { }).stdenvBootstrapTools));
12
13 in {
14
15 overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
16 overlays = { git-cache = self.overlay; };
17
18 packages = for-supported-systems (system: {
19 inherit (nixpkgs.legacyPackages."${system}".appendOverlays
20 [ self.overlay ])
21 git-cache;
22 });
23
24 defaultApp = for-supported-systems (system: {
25 type = "app";
26 program = "${self.packages."${system}".git-cache}/bin/git-cache";
27 });
28 };
29 }