1 { pkgs ? import <nixpkgs> { }, lint ? false }:
3 pkgs.python3Packages.callPackage
4 ({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
5 buildPythonPackage rec {
8 src = lib.cleanSource ./.;
9 propagatedBuildInputs = [ backoff ];
10 checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
12 checkPhase = "./test.sh";
14 description = "Cache git content locally";
15 homepage = "https://git.scottworley.com/git-cache";
16 license = pkgs.lib.licenses.gpl3;
17 maintainers = with pkgs.lib.maintainers; [ chkno ];