]> git.scottworley.com Git - auto-upgrade-with-pinch/blob - pkgs/homeless-gpg.nix
Use local pkgs instead of overlays
[auto-upgrade-with-pinch] / pkgs / homeless-gpg.nix
1 { coreutils, gnupg, writeShellScript }:
2 writeShellScript "homeless-gpg" ''
3 set -eo pipefail
4
5 export GNUPGHOME=$(${coreutils}/bin/mktemp -d)
6 trap '${coreutils}/bin/rm -r "$GNUPGHOME"' EXIT
7 ${gnupg}/bin/gpg --no-default-keyring "$@"
8 ''