4 fallback-git-cache = self.python3Packages.callPackage
5 ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
6 buildPythonPackage rec {
10 url = "https://git.scottworley.com/pub/git/git-cache";
12 hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
14 propagatedBuildInputs = [ backoff ];
15 checkInputs = [ git mypy ];
17 checkPhase = "./test.sh";
20 fallback-pinch = self.python3Packages.callPackage
21 ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
22 buildPythonPackage rec {
26 url = "https://git.scottworley.com/pub/git/pinch";
28 hash = "sha256-U3TOTfYvM1ONF9DJrWxfhjVQnY7GD96ru6A2Yj01lcg=";
30 buildInputs = [ makeWrapper ];
31 propagatedBuildInputs = [ git-cache ];
32 checkInputs = [ nix_2_3 git mypy ];
34 wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
37 checkPhase = "./test.sh";
38 }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
40 in { pinch = super.pinch or fallback-pinch; }