4 # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
5 fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
6 , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
7 buildPythonPackage rec {
10 src = fetchFromGitHub {
14 sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
17 nativeBuildInputs = [ poetry ];
18 checkInputs = [ pytestCheckHook pytest-asyncio ];
21 fallback-git-cache = self.python3Packages.callPackage
22 ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
23 buildPythonPackage rec {
27 url = "https://git.scottworley.com/pub/git/git-cache";
29 sha256 = "0awz7f6avzw9fk9gp1kadj0nbmf1s60qic9zb6ww92zig3khg12k";
31 propagatedBuildInputs = [ backoff ];
32 checkInputs = [ git mypy ];
34 checkPhase = "./test.sh";
35 }) { backoff = self.python3Packages.backoff or fallback-backoff; };
37 fallback-pinch = self.python3Packages.callPackage
38 ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
39 buildPythonPackage rec {
43 url = "https://git.scottworley.com/pub/git/pinch";
45 sha256 = "sha256-D1XC8pmemdOpIEWvS0VH9Fguvp92FqpQfJj2TudfwRw=";
47 buildInputs = [ makeWrapper ];
48 propagatedBuildInputs = [ git-cache ];
49 checkInputs = [ nix_2_3 git mypy ];
51 wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
54 checkPhase = "./test.sh";
55 }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
57 in { pinch = super.pinch or fallback-pinch; }