3 checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
4 (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
6 if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
8 fallback-git-cache = self.python3Packages.callPackage
9 ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
10 buildPythonPackage rec {
14 url = "https://git.scottworley.com/pub/git/git-cache";
16 hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
18 propagatedBuildInputs = [ backoff ];
19 "${checkInputsName}" = [ git mypy ];
21 checkPhase = "./test.sh";
24 fallback-pinch = self.python3Packages.callPackage
25 ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
26 buildPythonPackage rec {
30 url = "https://git.scottworley.com/pub/git/pinch";
32 hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
34 buildInputs = [ makeWrapper ];
35 propagatedBuildInputs = [ git-cache ];
36 "${checkInputsName}" = [ nix_2_3 git mypy ];
38 wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
41 checkPhase = "./test.sh";
42 }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
44 in { pinch = super.pinch or fallback-pinch; }