3 fallback-git-cache = self.python3Packages.callPackage
4 ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
5 buildPythonPackage rec {
9 url = "https://git.scottworley.com/pub/git/git-cache";
11 hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
13 propagatedBuildInputs = [ backoff ];
14 nativeCheckInputs = [ git mypy ];
16 checkPhase = "./test.sh";
19 fallback-pinch = self.python3Packages.callPackage
20 ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
21 buildPythonPackage rec {
25 url = "https://git.scottworley.com/pub/git/pinch";
27 hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
29 buildInputs = [ makeWrapper ];
30 propagatedBuildInputs = [ git-cache ];
31 nativeCheckInputs = [ nix_2_3 git mypy ];
33 wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
36 checkPhase = "./test.sh";
37 }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
39 in { pinch = super.pinch or fallback-pinch; }