]> git.scottworley.com Git - auto-upgrade-with-pinch/blob - overlays/pinch.nix
Only add pinch if not already present
[auto-upgrade-with-pinch] / overlays / pinch.nix
1 self: super: {
2 pinch = if builtins.hasAttr "pinch" super then
3 super.pinch
4 else
5 super.writeShellScriptBin "pinch" ''
6 exec ${self.python3}/bin/python3 ${
7 super.fetchgit {
8 url = "https://scottworley.com/pinch.git";
9 rev = "1.1";
10 sha256 = "0ilbhvr0d83kfwkm7ak64gik44gi2axfnp9rzsa7g5cwz9qaxdbv";
11 }
12 }/pinch.py "$@"
13 '';
14 }