4 # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
5 fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
6 , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
7 buildPythonPackage rec {
10 src = fetchFromGitHub {
14 sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
17 nativeBuildInputs = [ poetry ];
18 checkInputs = [ pytestCheckHook pytest-asyncio ];
21 fallback-git-cache = self.python3Packages.callPackage
22 ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
23 buildPythonPackage rec {
27 url = "https://scottworley.com/git-cache.git";
29 sha256 = "sha256-0HbtnS98im0sd2JIdUePBcspUskL2DY8ylQdyEC2sS0=";
31 propagatedBuildInputs = [ backoff ];
32 checkInputs = [ git mypy ];
34 checkPhase = "./test.sh";
35 }) { backoff = self.python3Packages.backoff or fallback-backoff; };
37 fallback-pinch = self.python3Packages.callPackage
38 ({ buildPythonPackage, fetchgit, nix, git, mypy, git-cache, }:
39 buildPythonPackage rec {
43 url = "https://scottworley.com/pinch.git";
45 sha256 = "sha256-bO0kMuaw/hkmDD1b8mkCDx0FAM6NIeUxvc+fOhHUXcs=";
47 propagatedBuildInputs = [ git-cache ];
48 checkInputs = [ nix git mypy ];
50 checkPhase = "./test.sh";
51 }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
53 in { pinch = super.pinch or fallback-pinch; }