3 checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
4 (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
6 if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
8 polite-merge = if builtins.hasAttr "polite-merge" super then
11 self.callPackage ({ fetchgit, git, stdenv, }:
12 stdenv.mkDerivation rec {
13 pname = "polite-merge";
16 url = "https://git.scottworley.com/pub/git/polite-merge";
18 sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
20 postUnpack = "patchShebangs .";
21 "${checkInputsName}" = [ git ];
23 preInstall = "export prefix";