+ clint.wait_for_file("/keys/cache-priv-key.pem")
+ clint_thread = Thread(
+ target=lambda: clint.succeed(
+ "${
+ mkConfig {
+ config = clientConfig;
+ trustixPubKeyPath = "/keys/alisha-signing-pub";
+ binaryCachePubKeyPath = "/keys/cache-priv-key.pem";
+ }
+ }",
+ "nixos-rebuild switch --show-trace",
+ )
+ )
+ clint_thread.start()
+