+ mkConfig =
+ { config, trustixPubKeyPath, binaryCachePubKeyPath ? "/dev/null", }:
+ writeShellScript "mkConfig" ''
+ set -euxo pipefail
+ mkdir -p /etc/nixos
+ ${gnused}/bin/sed "
+ s,@trustixPubKey@,$(< ${trustixPubKeyPath}),
+ s,@binaryCachePubKey@,$(< ${binaryCachePubKeyPath}),
+ " ${config} > /etc/nixos/local.nix
+ cat > /etc/nixos/configuration.nix <<EOF
+ {
+ imports = [
+ ${../lib/nixosTest-rebuild-switch.nix}
+ ${trustixModule}
+ ./local.nix
+ ];
+ }
+ EOF
+ '';
+