]> git.scottworley.com Git - rfc1751/blobdiff - default.nix
Release 1.0.0
[rfc1751] / default.nix
index 8b3e7506e93b7a87abd179a959d45a35055dd762..f1052a20e684741d92d65ab33cc83dfa3bb5fe40 100644 (file)
@@ -3,10 +3,16 @@ pkgs.python3Packages.callPackage
 ({ lib, buildPythonPackage, mypy, autopep8, pylint, }:
   buildPythonPackage rec {
     pname = "rfc1751";
-    version = "0.1.0";
+    version = "1.0.0";
     src = lib.cleanSource ./.;
     nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
-    meta = { license = lib.licenses.isc; };
+    meta = {
+      description =
+        "Command line tool for RFC1751 (aka S/Key) numbers-as-word-lists";
+      homepage = "https://git.scottworley.com/rfc1751";
+      license = lib.licenses.isc;
+      maintainers = with lib.maintainers; [ chkno ];
+    };
   }) { }