({ lib, buildPythonPackage, mypy, autopep8, pylint, }:
buildPythonPackage rec {
pname = "rfc1751";
- version = "0.1.0";
+ version = "1.0.0";
src = lib.cleanSource ./.;
nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
doCheck = true;
checkPhase = "./test.sh";
- meta = { license = lib.licenses.isc; };
+ meta = {
+ description =
+ "Command line tool for RFC1751 (aka S/Key) numbers-as-word-lists";
+ homepage = "https://git.scottworley.com/rfc1751";
+ license = lib.licenses.isc;
+ maintainers = with lib.maintainers; [ chkno ];
+ };
}) { }