-
- # Remove after https://github.com/NixOS/nixpkgs/pull/93377 reaches stable
- backoff-fallback = { lib, buildPythonPackage, fetchFromGitHub, pytestCheckHook
- , poetry, pytest-asyncio, }:
- buildPythonPackage rec {
- pname = "backoff";
- version = "1.10.0";
- src = fetchFromGitHub {
- owner = "litl";
- repo = pname;
- rev = "v${version}";
- sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
- };
- format = "pyproject";
- nativeBuildInputs = [ poetry ];
- checkInputs = [ pytestCheckHook pytest-asyncio ];
- };
+ checkInputsAreNative = pkgs.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";