git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.4.1";
+ version = "1.4.2";
src = fetchgit {
url = "https://git.scottworley.com/pub/git/git-cache";
rev = "v${version}";
- sha256 = "0ml1myhmd9mw1z5bwni9fhvx7h9dknhmqq4nyci9n5lvrhbmcdc9";
+ hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
};
propagatedBuildInputs = [ backoff ];
checkInputs = [ git mypy ];
, autopep8, makeWrapper, mypy, pylint, git-cache, }:
buildPythonPackage rec {
pname = "pinch";
- version = "3.0.10-pre";
+ version = "3.0.10";
src = lib.cleanSource ./.;
buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
'';
doCheck = true;
checkPhase = "./test.sh";
+ meta = {
+ description = "A replacement for `nix-channel --update`";
+ homepage = "https://git.scottworley.com/pinc";
+ license = pkgs.lib.licenses.gpl3;
+ maintainers = with pkgs.lib.maintainers; [ chkno ];
+ };
}) {
git-cache =
pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage