]> git.scottworley.com Git - pinch/blobdiff - shell.nix
Use xdg packge to find XDG cache dir
[pinch] / shell.nix
index b408ea4ba330739becfe23b5d71ed5ae0e6d1310..11e4f03df38198bcabaed52cabc35697a9beb716 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
 { pkgs ? import <nixpkgs> { } }:
 pkgs.mkShell rec {
   doCheck = true;
-  buildInputs = with pkgs; [ python3 ];
+  buildInputs = with pkgs; [ (python3.withPackages (ps: with ps; [ xdg ])) ];
   checkInputs = with pkgs; [
     mypy
     python3Packages.autopep8