]> git.scottworley.com Git - pinch/blobdiff - default.nix
Adapt to nixpkgs' nativeCheckInputs change
[pinch] / default.nix
index 94f525bb33fbe26401f462df744ae5c622d218d1..caebd9c961e727f6fdd1c9d188ffddbb35b84f9b 100644 (file)
@@ -1,6 +1,10 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 
 let
+  checkInputsAreNative = pkgs.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
     buildPythonPackage rec {
@@ -12,7 +16,7 @@ let
         hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
       };
       propagatedBuildInputs = [ backoff ];
-      checkInputs = [ git mypy ];
+      "${checkInputsName}" = [ git mypy ];
       doCheck = true;
       checkPhase = "./test.sh";
     };
@@ -25,7 +29,8 @@ in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
     src = lib.cleanSource ./.;
     buildInputs = [ makeWrapper ];
     propagatedBuildInputs = [ git-cache ];
-    checkInputs = [ nix_2_3 git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    "${checkInputsName}" = [ nix_2_3 git mypy ]
+      ++ lib.optionals lint [ autopep8 pylint ];
     postInstall = ''
       wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
     '';