]> git.scottworley.com Git - pinch/blobdiff - default.nix
Fix homepage URL
[pinch] / default.nix
index 31a63986b2376a9705e80980c08ff92b38f03c76..94f525bb33fbe26401f462df744ae5c622d218d1 100644 (file)
@@ -21,7 +21,7 @@ in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
   , autopep8, makeWrapper, mypy, pylint, git-cache, }:
   buildPythonPackage rec {
     pname = "pinch";
-    version = "3.0.10-pre";
+    version = "3.0.10";
     src = lib.cleanSource ./.;
     buildInputs = [ makeWrapper ];
     propagatedBuildInputs = [ git-cache ];
@@ -31,6 +31,12 @@ in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
     '';
     doCheck = true;
     checkPhase = "./test.sh";
+    meta = {
+      description = "A replacement for `nix-channel --update`";
+      homepage = "https://git.scottworley.com/pinch";
+      license = pkgs.lib.licenses.gpl3;
+      maintainers = with pkgs.lib.maintainers; [ chkno ];
+    };
   }) {
     git-cache =
       pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage