]> git.scottworley.com Git - pinch/blobdiff - default.nix
Appease new pylint
[pinch] / default.nix
index 20858fa1d17cef23ff4ef3291f0273f887d3025b..d397854b08c9c4c127c08e0c11891b1fe7b377e3 100644 (file)
@@ -1,55 +1,50 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 
 let
-
-  # Remove after https://github.com/NixOS/nixpkgs/pull/93377 reaches stable
-  backoff-fallback = { lib, buildPythonPackage, fetchFromGitHub, pytestCheckHook
-    , poetry, pytest-asyncio, }:
-    buildPythonPackage rec {
-      pname = "backoff";
-      version = "1.10.0";
-      src = fetchFromGitHub {
-        owner = "litl";
-        repo = pname;
-        rev = "v${version}";
-        sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
-      };
-      format = "pyproject";
-      nativeBuildInputs = [ poetry ];
-      checkInputs = [ pytestCheckHook pytest-asyncio ];
-    };
+  checkInputsAreNative = pkgs.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
     buildPythonPackage rec {
       pname = "git-cache";
-      version = "1.2.1";
+      version = "1.4.3";
       src = fetchgit {
-        url = "https://scottworley.com/git-cache.git";
+        url = "https://git.scottworley.com/pub/git/git-cache";
         rev = "v${version}";
-        sha256 = "16yh75176pnbzf48ak7q8lpfpr6digi130i5drxs6k2y9nf7g1jz";
+        hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
       };
       propagatedBuildInputs = [ backoff ];
-      checkInputs = [ git mypy ];
+      "${checkInputsName}" = [ git mypy ];
       doCheck = true;
       checkPhase = "./test.sh";
     };
 
-in pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, nix, git, autopep8, mypy, pylint, git-cache, }:
+in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
+  , autopep8, makeWrapper, mypy, pylint, git-cache, }:
   buildPythonPackage rec {
     pname = "pinch";
-    version = "3.0.2";
+    version = "3.0.12-pre";
     src = lib.cleanSource ./.;
+    buildInputs = [ makeWrapper ];
     propagatedBuildInputs = [ git-cache ];
-    checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    "${checkInputsName}" = [ nix_2_3 git mypy ]
+      ++ lib.optionals lint [ autopep8 pylint ];
+    postInstall = ''
+      wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+    '';
     doCheck = true;
     checkPhase = "./test.sh";
+    meta = {
+      description = "A replacement for `nix-channel --update`";
+      homepage = "https://git.scottworley.com/pinch";
+      license = pkgs.lib.licenses.gpl3;
+      maintainers = with pkgs.lib.maintainers; [ chkno ];
+    };
   }) {
     git-cache =
       pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage
-        git-cache-fallback {
-          backoff =
-            pkgs.python3Packages.backoff or (pkgs.python3Packages.callPackage
-              backoff-fallback { });
-        });
+        git-cache-fallback { });
+    nix_2_3 = pkgs.nix_2_3 or pkgs.nix;
   }