let
- # Remove after https://github.com/NixOS/nixpkgs/pull/93377 reaches stable
- backoff-fallback = { lib, buildPythonPackage, fetchFromGitHub, pytestCheckHook
- , poetry, pytest-asyncio, }:
- buildPythonPackage rec {
- pname = "backoff";
- version = "1.10.0";
- src = fetchFromGitHub {
- owner = "litl";
- repo = pname;
- rev = "v${version}";
- sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
- };
- format = "pyproject";
- nativeBuildInputs = [ poetry ];
- checkInputs = [ pytestCheckHook pytest-asyncio ];
- };
-
git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.2.1";
+ version = "1.4.2";
src = fetchgit {
- url = "https://scottworley.com/git-cache.git";
+ url = "https://git.scottworley.com/pub/git/git-cache";
rev = "v${version}";
- sha256 = "16yh75176pnbzf48ak7q8lpfpr6digi130i5drxs6k2y9nf7g1jz";
+ hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
};
propagatedBuildInputs = [ backoff ];
checkInputs = [ git mypy ];
checkPhase = "./test.sh";
};
-in pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, nix, git, autopep8, mypy, pylint, git-cache, }:
+in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
+ , autopep8, makeWrapper, mypy, pylint, git-cache, }:
buildPythonPackage rec {
pname = "pinch";
- version = "3.0.3-pre";
+ version = "3.0.10-pre";
src = lib.cleanSource ./.;
+ buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
- checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+ checkInputs = [ nix_2_3 git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+ postInstall = ''
+ wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+ '';
doCheck = true;
checkPhase = "./test.sh";
}) {
git-cache =
pkgs.python3Packages.git-cache or (pkgs.python3Packages.callPackage
- git-cache-fallback {
- backoff =
- pkgs.python3Packages.backoff or (pkgs.python3Packages.callPackage
- backoff-fallback { });
- });
+ git-cache-fallback { });
+ nix_2_3 = pkgs.nix_2_3 or pkgs.nix;
}