]> git.scottworley.com Git - pinch/blobdiff - default.nix
Release 3.0.12
[pinch] / default.nix
index e62e1d39ae379784beda2c1f64538f77fa826da9..00ddac98d4f7d141029d25f711a6e2ca523a5d07 100644 (file)
@@ -1,18 +1,22 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 
 let
+  checkInputsAreNative = pkgs.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   git-cache-fallback = { buildPythonPackage, fetchgit, git, backoff, mypy, }:
     buildPythonPackage rec {
       pname = "git-cache";
-      version = "1.4.2";
+      version = "1.4.3";
       src = fetchgit {
         url = "https://git.scottworley.com/pub/git/git-cache";
         rev = "v${version}";
-        hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
+        hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
       };
       propagatedBuildInputs = [ backoff ];
-      checkInputs = [ git mypy ];
+      "${checkInputsName}" = [ git mypy ];
       doCheck = true;
       checkPhase = "./test.sh";
     };
@@ -21,11 +25,12 @@ in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
   , autopep8, makeWrapper, mypy, pylint, git-cache, }:
   buildPythonPackage rec {
     pname = "pinch";
-    version = "3.0.10";
+    version = "3.0.12";
     src = lib.cleanSource ./.;
     buildInputs = [ makeWrapper ];
     propagatedBuildInputs = [ git-cache ];
-    checkInputs = [ nix_2_3 git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    "${checkInputsName}" = [ nix_2_3 git mypy ]
+      ++ lib.optionals lint [ autopep8 pylint ];
     postInstall = ''
       wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
     '';
@@ -33,7 +38,7 @@ in pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, nix_2_3, git
     checkPhase = "./test.sh";
     meta = {
       description = "A replacement for `nix-channel --update`";
-      homepage = "https://git.scottworley.com/pinc";
+      homepage = "https://git.scottworley.com/pinch";
       license = pkgs.lib.licenses.gpl3;
       maintainers = with pkgs.lib.maintainers; [ chkno ];
     };